Codebase list httping / e1dc65df-7c73-4830-8ed4-9f60ff1e4b6c/main debian / rules
e1dc65df-7c73-4830-8ed4-9f60ff1e4b6c/main

Tree @e1dc65df-7c73-4830-8ed4-9f60ff1e4b6c/main (Download .tar.gz)

rules @e1dc65df-7c73-4830-8ed4-9f60ff1e4b6c/mainraw · history · blame

#!/usr/bin/make -f

export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_BUILD_HARDENING=1
include /usr/share/dpkg/buildflags.mk
-include /usr/share/dpkg/buildtools.mk
export CC

%:
	dh $@

override_dh_auto_install:
	$(MAKE) install PREFIX=$(CURDIR)/debian/httping/usr
	rm $(CURDIR)/debian/httping/usr/share/doc/httping/license.txt
	rm $(CURDIR)/debian/httping/usr/share/doc/httping/license.OpenSSL

override_dh_auto_configure:
	./configure --with-tfo --with-ncurses --with-openssl --with-fftw3