Codebase list ibutils / 4af1a6c debian / patches / Always-update-man-pages-if-needed.patch
4af1a6c

Tree @4af1a6c (Download .tar.gz)

Always-update-man-pages-if-needed.patch @4af1a6craw · history · blame

From e4b6018e5237bbfb545adee251e531f4a5ef2d45 Mon Sep 17 00:00:00 2001
From: Benjamin Drung <benjamin.drung@cloud.ionos.com>
Date: Wed, 11 Nov 2020 11:56:40 +0100
Subject: Always update man pages if needed

Removing the man pages and not activating the automake maintainer mode
let the build fail:

```
make[4]: Entering directory '/<<PKGBUILDDIR>>/ibis/doc'
./ibis_pod2man  ibis.1
Usage ./ibis_pod2man podFile [outFile]
Given podFile:ibis.1 extension != .pod
make[4]: *** [Makefile:568: ibis.1] Error 1
```

So always update the man pages if needed.

Signed-off-by: Benjamin Drung <benjamin.drung@cloud.ionos.com>
---
 ibdm/doc/Makefile.am     | 2 +-
 ibis/doc/Makefile.am     | 2 +-
 ibmgtsim/doc/Makefile.am | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/ibdm/doc/Makefile.am b/ibdm/doc/Makefile.am
index bc28a03..e651510 100644
--- a/ibdm/doc/Makefile.am
+++ b/ibdm/doc/Makefile.am
@@ -46,7 +46,7 @@ EXTRA_DIST = \
 	ibtopodiff.pod     ibtopodiff.1 \
 	ibdm_pod2man
 
-%.1: @MAINTAINER_MODE_TRUE@ %.pod
+%.1: %.pod
 	$(srcdir)/ibdm_pod2man $< $@
 	if test ! $@ -ef $(srcdir)/$@ ; then cp -f $@ $(srcdir)/$@; fi
 
diff --git a/ibis/doc/Makefile.am b/ibis/doc/Makefile.am
index 5509865..24dc392 100644
--- a/ibis/doc/Makefile.am
+++ b/ibis/doc/Makefile.am
@@ -34,6 +34,6 @@ man_MANS = ibis.1
 
 EXTRA_DIST = ibis.pod ibis.1
 
-%.1: @MAINTAINER_MODE_TRUE@ %.pod
+%.1: %.pod
 	$(srcdir)/ibis_pod2man $< $@
 	if test ! $@ -ef $(srcdir)/$@ ; then cp -f $@ $(srcdir)/$@; fi
diff --git a/ibmgtsim/doc/Makefile.am b/ibmgtsim/doc/Makefile.am
index a9c0237..b7a6969 100644
--- a/ibmgtsim/doc/Makefile.am
+++ b/ibmgtsim/doc/Makefile.am
@@ -37,6 +37,6 @@ EXTRA_DIST = \
 	IBMgtSim.pod RunSimTest.pod ibmsquit.pod mkSimNodeDir.pod ibmssh.pod \
 	ibmgtsim_pod2man
 
-%.1: @MAINTAINER_MODE_TRUE@ %.pod
+%.1: %.pod
 	$(srcdir)/ibmgtsim_pod2man $< $@
 	if test ! $@ -ef $(srcdir)/$@ ; then cp -f $@ $(srcdir)/$@; fi
-- 
2.25.1