Codebase list ibutils / 944b3f27-e329-4dd2-a08d-4b990aa9538d/main debian / rules
944b3f27-e329-4dd2-a08d-4b990aa9538d/main

Tree @944b3f27-e329-4dd2-a08d-4b990aa9538d/main (Download .tar.gz)

rules @944b3f27-e329-4dd2-a08d-4b990aa9538d/mainraw · history · blame

#!/usr/bin/make -f
# -*- makefile -*-

%:
	dh $@

override_dh_auto_configure:
	dh_auto_configure -- --with-osm=/usr \
	--with-osm-libs=/usr/lib/$(DEB_HOST_MULTIARCH) \
	--with-tk-lib=/usr/lib/$(DEB_HOST_MULTIARCH)/libtk.so


override_dh_auto_install:
	dh_auto_install
	chmod ogu-x debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/ibdm1.5.7/ibnl/*.ibnl
	rm -f debian/tmp/usr/bin/*.pl debian/tmp/usr/bin/*.tcl debian/tmp/usr/lib/*/*.la

override_dh_auto_clean:
	dh_auto_clean
	rm -f $(shell find -name '*.pod' | sed 's/\.pod/.1/')