Codebase list ibutils / c5f27a6 debian / patches / 01_topomatch_diff.patch
c5f27a6

Tree @c5f27a6 (Download .tar.gz)

01_topomatch_diff.patch @c5f27a6raw · history · blame

From: <benoit.mortier@opensides.be>
Subject: fix char * problem


--- ibutils-1.2-OFED-1.4.2.orig/ibdm/ibdm/TopoMatch.cpp
+++ ibutils-1.2-OFED-1.4.2/ibdm/ibdm/TopoMatch.cpp
@@ -676,7 +676,7 @@
   IBSystem *p_system = p_node->p_system;

   // we always mark the board of the node by examining all but the "UXXX"
-  char *p_lastSlash = rindex(p_node->name.c_str(), '/');
+  const char *p_lastSlash = rindex(p_node->name.c_str(), '/');
   char nodeBoardName[512];
   int  boardNameLength;
   if (!p_lastSlash) {