Codebase list ibutils / debian/1.5.7-3 debian / patches / 03-remove-rpath.patch
debian/1.5.7-3

Tree @debian/1.5.7-3 (Download .tar.gz)

03-remove-rpath.patch @debian/1.5.7-3raw · history · blame

Description: Patch autotools files to avoid unecessary rpaths in executables
Author: Roland Dreier <rbd@debian.org>

--- a/config/osm.m4
+++ b/config/osm.m4
@@ -114,7 +114,7 @@
    fi
    AC_MSG_NOTICE(OSM: build type $OSM_BUILD)
 
-   OSM_LDFLAGS="-Wl,-rpath -Wl,$with_osm_libs -L$with_osm_libs"
+   OSM_LDFLAGS="-L$with_osm_libs"
    dnl based on the with_osm dir and the libs available
    dnl we can try and decide what vendor was used:
    if test $OSM_BUILD = openib; then
--- a/ibis/config/osm.m4
+++ b/ibis/config/osm.m4
@@ -114,7 +114,7 @@
    fi
    AC_MSG_NOTICE(OSM: build type $OSM_BUILD)
 
-   OSM_LDFLAGS="-Wl,-rpath -Wl,$with_osm_libs -L$with_osm_libs"
+   OSM_LDFLAGS="-L$with_osm_libs"
    dnl based on the with_osm dir and the libs available
    dnl we can try and decide what vendor was used:
    if test $OSM_BUILD = openib; then
--- a/ibmgtsim/config/osm.m4
+++ b/ibmgtsim/config/osm.m4
@@ -114,7 +114,7 @@
    fi
    AC_MSG_NOTICE(OSM: build type $OSM_BUILD)
 
-   OSM_LDFLAGS="-Wl,-rpath -Wl,$with_osm_libs -L$with_osm_libs"
+   OSM_LDFLAGS="-L$with_osm_libs"
    dnl based on the with_osm dir and the libs available
    dnl we can try and decide what vendor was used:
    if test $OSM_BUILD = openib; then
--- a/ibdm/ibdm/Makefile.am
+++ b/ibdm/ibdm/Makefile.am
@@ -80,12 +80,12 @@
 
 libibdm_la_SOURCES = ibdm_wrap.cpp ibdm.i $(common_SOURCES)
 libibdm_la_LIBADD = $(TCL_LIBS) 
-libibdm_la_LDFLAGS = -Wl,-rpath -Wl,$(TCL_PREFIX)/lib -version-info $(LIB_VER_TRIPLET) -no-undefined
+libibdm_la_LDFLAGS = -version-info $(LIB_VER_TRIPLET) -no-undefined
 
 bin_PROGRAMS  = ibdmsh
 ibdmsh_SOURCES = ibdmsh_wrap.cpp
 ibdmsh_LDADD =  -libdmcom $(TCL_LIBS)
-ibdmsh_LDFLAGS = -static -Wl,-rpath -Wl,$(TCL_PREFIX)/lib
+ibdmsh_LDFLAGS = -static
 ibdmsh_DEPENDENCIES=$(lib_LTLIBRARIES)
 
 $(srcdir)/Fabric.cpp: $(srcdir)/git_version.h
--- a/ibmgtsim/src/Makefile.am
+++ b/ibmgtsim/src/Makefile.am
@@ -76,8 +76,7 @@
 ibmssh_SOURCES = sim.cpp server.cpp node.cpp dispatcher.cpp \
 	 ibmssh_wrap.cpp sma.cpp pma.cpp vsa.cpp randmgr.cpp
 
-ibmssh_LDFLAGS = -static -Wl,-rpath -Wl,$(TCL_PREFIX)/lib \
-	-Wl,-rpath -Wl,$(IBDM_PREFIX)/lib
+ibmssh_LDFLAGS = -static
 
 ibmssh_LDADD = -libmscli $(IBDM_LIB) $(TCL_LIBS) -lpthread