Codebase list ibutils / run/7a17c858-3b4d-4f00-b7f7-4421e18567ad/main debian / rules
run/7a17c858-3b4d-4f00-b7f7-4421e18567ad/main

Tree @run/7a17c858-3b4d-4f00-b7f7-4421e18567ad/main (Download .tar.gz)

rules @run/7a17c858-3b4d-4f00-b7f7-4421e18567ad/mainraw · history · blame

#!/usr/bin/make -f
# -*- makefile -*-

%:
	dh $@

override_dh_auto_configure:
	dh_auto_configure -- --with-osm=/usr \
	--with-osm-libs=/usr/lib/$(DEB_HOST_MULTIARCH) \
	--with-tk-lib=/usr/lib/$(DEB_HOST_MULTIARCH)/libtk.so


override_dh_auto_install:
	dh_auto_install
	chmod ogu-x debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/ibdm1.5.7/ibnl/*.ibnl
	rm -f debian/tmp/usr/bin/*.pl debian/tmp/usr/bin/*.tcl debian/tmp/usr/lib/*/*.la

override_dh_auto_clean:
	dh_auto_clean
	rm -f $(shell find -name '*.pod' | sed 's/\.pod/.1/')