Codebase list kwindowsystem / 133b1e0 debian / rules
133b1e0

Tree @133b1e0 (Download .tar.gz)

rules @133b1e0raw · history · blame

#!/usr/bin/make -f
# -*- makefile -*-

export DEB_LDFLAGS_MAINT_APPEND := -Wl,--as-needed

%:
	dh $@ --with kf5,pkgkde_symbolshelper --buildsystem kf5 --without build_stamp

override_dh_auto_configure:
	dh_auto_configure -- -DBUILD_QCH=ON -DBUILD_TESTING=OFF

override_dh_strip:
	dh_strip --dbgsym-migration='libkf5windowsystem5-dbg (<= 5.19.0-1~~)'

override_dh_auto_test:
	# Disable auto tests at build time
	: