Codebase list kwindowsystem / 4dc18f2 debian / patches / test_depends_on_stack_pointer
4dc18f2

Tree @4dc18f2 (Download .tar.gz)

test_depends_on_stack_pointer @4dc18f2raw · history · blame

Index: kwindowsystem/autotests/kwindowsystemx11test.cpp
===================================================================
--- kwindowsystem.orig/autotests/kwindowsystemx11test.cpp	2015-03-14 12:17:52.249187796 +0100
+++ kwindowsystem/autotests/kwindowsystemx11test.cpp	2015-03-14 19:35:10.000782148 +0100
@@ -312,10 +312,11 @@
             continue;
         }
         if ((*it).at(0).toULongLong() == widget.winId()) {
-            const unsigned long *props = (*it).at(1).value<const unsigned long *>();
-            if (props[0] & NET::WMName) {
+            // This was emited from a stack pointer, so not really useful
+            // const unsigned long *props = (*it).at(1).value<const unsigned long *>();
+            // if (props[0] & NET::WMName) {
                 gotWMName = true;
-            }
+            // }
         }
         if (gotWMName) {
             break;