Codebase list libatasmart / b81edd64-90df-473e-9334-b3c56626da0f/main debian / rules
b81edd64-90df-473e-9334-b3c56626da0f/main

Tree @b81edd64-90df-473e-9334-b3c56626da0f/main (Download .tar.gz)

rules @b81edd64-90df-473e-9334-b3c56626da0f/mainraw · history · blame

#!/usr/bin/make -f

%:
	dh $@

export DEB_LDFLAGS_MAINT_APPEND := -Wl,--as-needed

override_dh_install:
	dh_install
	# when building for Ubuntu, install Apport hook
	if dpkg-vendor --is ubuntu; then \
	    install -m 644 -D debian/local/apport-hook.py debian/libatasmart4/usr/share/apport/package-hooks/libatasmart4.py; \
	fi

override_dh_installdocs:
	dh_installdocs --all README