Codebase list libjdom2-intellij-java / 8d0c7f64-c544-4786-ae83-9770bded5e2f/main debian / rules
8d0c7f64-c544-4786-ae83-9770bded5e2f/main

Tree @8d0c7f64-c544-4786-ae83-9770bded5e2f/main (Download .tar.gz)

rules @8d0c7f64-c544-4786-ae83-9770bded5e2f/mainraw · history · blame

#!/usr/bin/make -f

%:
	dh $@ --buildsystem=gradle --with maven-repo-helper

override_dh_auto_clean:
	-[ -f contrib/build.gradle ] && mv -f contrib/build.gradle.orig contrib/build.gradle
	dh_auto_clean

override_dh_auto_build:
	cp contrib/build.gradle contrib/build.gradle.orig
	echo "sourceCompatibility = '1.7'" >> contrib/build.gradle
	echo "targetCompatibility = '1.7'" >> contrib/build.gradle
	dh_auto_build -- assemble javaDoc