Codebase list libmawk / c18583c0-bfa6-44ff-88f7-5aa9a2739ad8/main debian / rules
c18583c0-bfa6-44ff-88f7-5aa9a2739ad8/main

Tree @c18583c0-bfa6-44ff-88f7-5aa9a2739ad8/main (Download .tar.gz)

rules @c18583c0-bfa6-44ff-88f7-5aa9a2739ad8/mainraw · history · blame

#!/usr/bin/make -f

DH_VERBOSE = 1
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk

%:
	dh $@

override_dh_auto_configure:
	./configure \
    --prefix=/usr \
    --LDFLAGS='$(LDFLAGS)' \
    --CFLAGS='$(CFLAGS) $(CPPFLAGS)'

override_dh_auto_clean:
	# only try to run dh_auto_clean if configure has been run
	test -f src/libmawk/Makefile.conf && dh_auto_clean || true