Codebase list libmawk / debian/1.0.0-2 debian / rules
debian/1.0.0-2

Tree @debian/1.0.0-2 (Download .tar.gz)

rules @debian/1.0.0-2raw · history · blame

#!/usr/bin/make -f

DH_VERBOSE = 1
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk

%:
	dh $@

override_dh_auto_configure:
	./configure \
    --prefix=/usr \
    --LDFLAGS='$(LDFLAGS)' \
    --CFLAGS='$(CFLAGS) $(CPPFLAGS)'

override_dh_auto_clean:
	# only try to run dh_auto_clean if configure has been run
	test -f src/libmawk/Makefile.conf && dh_auto_clean || true