Codebase list libmicroba-java / debian/1e0.4.4.2-1 debian / rules
debian/1e0.4.4.2-1

Tree @debian/1e0.4.4.2-1 (Download .tar.gz)

rules @debian/1e0.4.4.2-1raw · history · blame

#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

include /usr/share/quilt/quilt.make

TARBALL ?= $(shell uscan --force-download --verbose | tail -n 2 | perl -ne 'print $$_ if s;.*(microba-[\d\.]+-full.zip).*;../$$1;')
VERSION ?= $(shell echo $(TARBALL) | perl -pe 's;../microba-(.+)-full.zip;$$1;')
TMPDIR  := $(shell mktemp -d)

get-orig-source:
	unzip $(TARBALL) -d $(TMPDIR)/libmicroba-java-$(VERSION)
	cd $(TMPDIR) && tar cfz libmicroba-java-$(VERSION).tar.gz libmicroba-java-$(VERSION) && cd $(CURDIR)
	mv $(TMPDIR)/libmicroba-java-$(VERSION).tar.gz $(CURDIR)/../
	rm -rf $(TMPDIR)

configure: configure-stamp
configure-stamp: 
	dh_testdir
	unzip $(CURDIR)/microba-*-sources.jar -d src
	touch $@

build: build-stamp
build-stamp: configure-stamp $(QUILT_STAMPFN)
	dh_testdir
	JAVA_HOME=/usr/lib/jvm/java-gcj ant -f $(CURDIR)/src/build.xml bin_release doc_release
	touch $@

clean: unpatch
	dh_testdir
	dh_testroot
	rm -f build-stamp configure-stamp install-stamp
	rm -rf src
	dh_clean 

install: install-stamp
install-stamp: build-stamp
	dh_testdir
	dh_testroot
	dh_clean -k 
	dh_installdirs
	touch $@

# Build architecture-independent files here.
binary-indep: build install
	dh_testdir
	dh_testroot
	dh_installchangelogs src/change.log.txt
	dh_installdocs
	dh_install
	dh_link
	dh_compress
	dh_fixperms
	dh_installdeb
	dh_shlibdeps
	dh_gencontrol
	dh_md5sums
	dh_builddeb


# Build architecture-dependent files here.
binary-arch: build install
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure