nice, a couple of files missing in git :/
Git-Dch: Ignore
gregor herrmann
11 years ago
|
0 |
Description: use Debian libraries
|
|
1 |
Forwarded: no
|
|
2 |
Author: gregor herrmann <gregoa@debian.org>
|
|
3 |
Last-Update: 2012-04-18
|
|
4 |
|
|
5 |
--- a/build.xml
|
|
6 |
+++ b/build.xml
|
|
7 |
@@ -6,7 +6,7 @@
|
|
8 |
<project default="jar" name="commons-java" basedir=".">
|
|
9 |
<property name="defaulttargetdir" value="target">
|
|
10 |
</property>
|
|
11 |
- <property name="libdir" value="target/lib">
|
|
12 |
+ <property name="libdir" value="/usr/share/java">
|
|
13 |
</property>
|
|
14 |
<property name="classesdir" value="target/classes">
|
|
15 |
</property>
|
|
16 |
@@ -29,8 +29,10 @@
|
|
17 |
</fileset>
|
|
18 |
</path>
|
|
19 |
<target name="init" description="o Initializes some properties">
|
|
20 |
+ <!--
|
|
21 |
<mkdir dir="${libdir}">
|
|
22 |
</mkdir>
|
|
23 |
+ -->
|
|
24 |
<condition property="noget">
|
|
25 |
<equals arg2="only" arg1="${build.sysclasspath}">
|
|
26 |
</equals>
|
|
27 |
@@ -163,4 +165,4 @@
|
|
28 |
<unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
|
|
29 |
</unjar>
|
|
30 |
</target>
|
|
31 |
-</project>
|
|
32 |
\ No newline at end of file
|
|
33 |
+</project>
|
|
0 |
#!/usr/bin/make -f
|
|
1 |
# -*- makefile -*-
|
|
2 |
# Sample debian/rules that uses debhelper.
|
|
3 |
# This file was originally written by Joey Hess and Craig Small.
|
|
4 |
# As a special exception, when this file is copied by dh-make into a
|
|
5 |
# dh-make output file, you may use that output file without restriction.
|
|
6 |
# This special exception was added by Craig Small in version 0.37 of dh-make.
|
|
7 |
|
|
8 |
# Uncomment this to turn on verbose mode.
|
|
9 |
#export DH_VERBOSE=1
|
|
10 |
|
|
11 |
include /usr/share/quilt/quilt.make
|
|
12 |
|
|
13 |
build: build-stamp
|
|
14 |
build-stamp: $(QUILT_STAMPFN)
|
|
15 |
dh_testdir
|
|
16 |
JAVA_HOME=/usr/lib/jvm/default-java ant -Dnoget=true jar javadoc
|
|
17 |
touch $@
|
|
18 |
|
|
19 |
clean: unpatch
|
|
20 |
dh_testdir
|
|
21 |
dh_testroot
|
|
22 |
ant clean
|
|
23 |
dh_clean build-stamp install-stamp
|
|
24 |
|
|
25 |
install: install-stamp
|
|
26 |
install-stamp: build-stamp
|
|
27 |
dh_testdir
|
|
28 |
dh_testroot
|
|
29 |
dh_clean -k
|
|
30 |
touch $@
|
|
31 |
|
|
32 |
binary-indep: build install
|
|
33 |
dh_testdir
|
|
34 |
dh_testroot
|
|
35 |
dh_installchangelogs
|
|
36 |
dh_installdocs
|
|
37 |
dh_install
|
|
38 |
dh_installman
|
|
39 |
dh_link
|
|
40 |
dh_compress
|
|
41 |
dh_fixperms
|
|
42 |
dh_installdeb
|
|
43 |
dh_gencontrol
|
|
44 |
dh_md5sums
|
|
45 |
dh_builddeb
|
|
46 |
|
|
47 |
binary-arch: build install
|
|
48 |
|
|
49 |
binary: binary-indep binary-arch
|
|
50 |
.PHONY: build clean binary-indep binary-arch binary install
|
|
0 |
version=3
|
|
1 |
http://sf.net/onemind-commons/commons-java-(.*)-src\.tar\.gz
|