Codebase list libsdl2-mixer / 7fb2f10 debian / patches / 04_timidity_cfg_opts.patch
7fb2f10

Tree @7fb2f10 (Download .tar.gz)

04_timidity_cfg_opts.patch @7fb2f10raw · history · blame

Description: Ignore unknown options in timidity.cfg
 Introduced in 1.2.8-6 (Fri, 22 May 2009 10:33:13 -0400).
Author: Brandon Barnes <winterknight@nerdshack.com>
Last-Update: 2012-01-20
Bug-Debian: http://bugs.debian.org/398805
--- a/timidity/timidity.c
+++ b/timidity/timidity.c
@@ -153,7 +153,7 @@
     {
      ctl->cmsg(CMSG_ERROR, VERB_NORMAL,
         "%s: line %d: syntax error\n", name, line);
-     return -2;
+     continue;
     }
   i=atoi(w[0]);
   if (i<0 || i>127)