d/patches: remove fix-750706-upstream-8ef083375857.patch, backported from upstream
Manuel A. Fernandez Montecelo
7 years ago
2 | 2 |
* New upstream release
|
3 | 3 |
* d/examples/Makefile: link against SDL2_mixer. Thanks Riku Saikkonen.
|
4 | 4 |
(Closes: #774717)
|
|
5 |
* d/patches:
|
|
6 |
- Remove fix-750706-upstream-8ef083375857.patch, backported from upstream
|
5 | 7 |
|
6 | 8 |
-- Manuel A. Fernandez Montecelo <mafm@debian.org> Tue, 26 Jan 2016 16:08:39 +0000
|
7 | 9 |
|
debian/patches/fix-750706-upstream-8ef083375857.patch
less
more
0 | |
|
1 | |
# HG changeset patch
|
2 | |
# User Sam Lantinga <slouken@libsdl.org>
|
3 | |
# Date 1383514401 28800
|
4 | |
# Node ID 8ef0833758572b84317ba19cc5a1eb2719552da3
|
5 | |
# Parent c166c70fc52a33324945156318ad7454a366eb30
|
6 | |
Fixed bug 2140 - Track is played back with the wrong tempo
|
7 | |
|
8 | |
ny00
|
9 | |
|
10 | |
It seems like the test against MAXCHAN can safely be relocated after the check if (meep->event.type==ME_TEMPO), with no risk of memory corruption, at least in this function.
|
11 | |
|
12 | |
diff -r c166c70fc52a -r 8ef083375857 timidity/readmidi.c
|
13 | |
--- a/timidity/readmidi.c Sun Nov 03 11:31:19 2013 -0800
|
14 | |
+++ b/timidity/readmidi.c Sun Nov 03 13:33:21 2013 -0800
|
15 | |
@@ -673,15 +673,15 @@
|
16 | |
meep->event.time, meep->event.channel + 1,
|
17 | |
meep->event.type, meep->event.a, meep->event.b);
|
18 | |
|
19 | |
- if (meep->event.channel >= MAXCHAN)
|
20 | |
- skip_this_event=1;
|
21 | |
- else if (meep->event.type==ME_TEMPO)
|
22 | |
+ if (meep->event.type==ME_TEMPO)
|
23 | |
{
|
24 | |
tempo=
|
25 | |
meep->event.channel + meep->event.b * 256 + meep->event.a * 65536;
|
26 | |
compute_sample_increment(tempo, divisions);
|
27 | |
skip_this_event=1;
|
28 | |
}
|
29 | |
+ else if (meep->event.channel >= MAXCHAN)
|
30 | |
+ skip_this_event=1;
|
31 | |
else if ((quietchannels & (1<<meep->event.channel)))
|
32 | |
skip_this_event=1;
|
33 | |
else switch (meep->event.type)
|
34 | |
|