Codebase list libxstream-java / debian/1.4.7-2 debian / control
debian/1.4.7-2

Tree @debian/1.4.7-2 (Download .tar.gz)

control @debian/1.4.7-2raw · history · blame

Source: libxstream-java
Section: java
Priority: optional
Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Uploaders: Torsten Werner <twerner@debian.org>,
           Varun Hiremath <varun@debian.org>,
           Damien Raude-Morvan <drazzib@debian.org>,
           Emmanuel Bourg <ebourg@apache.org>
Build-Depends: ant,
               cdbs,
               debhelper (>= 9),
               default-jdk,
               javahelper,
               libcglib3-java,
               libdom4j-java,
               libjdom1-java,
               libjdom2-java,
               libjettison-java,
               libjoda-time-java,
               libkxml2-java,
               libstax-java,
               libstax2-api-java,
               libwoodstox-java,
               libxom-java,
               libxpp3-java,
               maven-ant-helper,
               maven-repo-helper
Standards-Version: 3.9.6
Vcs-Svn: svn://anonscm.debian.org/pkg-java/trunk/libxstream-java
Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-java/trunk/libxstream-java
Homepage: http://xstream.codehaus.org

Package: libxstream-java
Architecture: all
Depends: libxpp3-java, ${misc:Depends}
Suggests: libcglib3-java,
          libdom4j-java,
          libjdom1-java,
          libjdom2-java,
          libjettison-java,
          libjoda-time-java,
          libkxml2-java,
          libstax-java,
          libstax2-api-java,
          libwoodstox-java,
          libxom-java
Description: Java library to serialize objects to XML and back again
 The features of the XStream library are:
 .
  - Ease of use. A high level facade is supplied that simplifies common
    use cases.
  - No mappings required. Most objects can be serialized without need
    for specifying mappings.
  - Performance. Speed and low memory footprint are a crucial part of
    the design, making it suitable for large object graphs or systems
    with high message throughput.
  - Clean XML. No information is duplicated that can be obtained via
    reflection. This results in XML that is easier to read for humans
    and more compact than native Java serialization.
  - Requires no modifications to objects. Serializes internal fields,
    including private and final. Supports non-public and inner classes.
    Classes are not required to have default constructor.
  - Full object graph support. Duplicate references encountered in the
    object-model will be maintained. Supports circular references.
  - Integrates with other XML APIs. By implementing an interface,
    XStream can serialize directly to/from any tree structure (not just
    XML).
  - Customizable conversion strategies. Strategies can be registered
    allowing customization of how particular types are represented as
    XML.
  - Error messages. When an exception occurs due to malformed XML,
    detailed diagnostics are provided to help isolate and fix the
    problem.
  - Alternative output format. The modular design allows other output
    formats. XStream ships currently with JSON support and morphing.