Codebase list logbook / 61db662a-aa54-48c2-8f42-facbd50b4153/main debian / patches / use-cython3.patch
61db662a-aa54-48c2-8f42-facbd50b4153/main

Tree @61db662a-aa54-48c2-8f42-facbd50b4153/main (Download .tar.gz)

use-cython3.patch @61db662a-aa54-48c2-8f42-facbd50b4153/mainraw · history · blame

--- a/Makefile
+++ b/Makefile
@@ -25,11 +25,11 @@ docs:
 	make -C docs html SPHINXOPTS=-Aonline=1
 
 release: logbook/_speedups.so
-	python scripts/make-release.py
+	@python scripts/make-release.py
 
 logbook/_speedups.so: logbook/_speedups.pyx
-	cython logbook/_speedups.pyx
-	python setup.py build_ext --inplace
+	cython3 logbook/_speedups.pyx
+	python3 setup.py build_ext --inplace
 
 cybuild: logbook/_speedups.so