Codebase list logbook / 6d5b6d41-baea-4550-8468-50abf853ee3c/main debian / patches / use-cython3.patch
6d5b6d41-baea-4550-8468-50abf853ee3c/main

Tree @6d5b6d41-baea-4550-8468-50abf853ee3c/main (Download .tar.gz)

use-cython3.patch @6d5b6d41-baea-4550-8468-50abf853ee3c/mainraw · history · blame

Description: Use cython3
--- a/Makefile
+++ b/Makefile
@@ -25,11 +25,11 @@ docs:
 	make -C docs html SPHINXOPTS=-Aonline=1
 
 release: logbook/_speedups.so
-	python scripts/make-release.py
+	@python scripts/make-release.py
 
 logbook/_speedups.so: logbook/_speedups.pyx
-	cython logbook/_speedups.pyx
-	python setup.py build_ext --inplace
+	cython3 logbook/_speedups.pyx
+	python3 setup.py build_ext --inplace
 
 cybuild: logbook/_speedups.so