Codebase list logbook / 71235d0b-adb4-4b86-8514-d1693dc35069/main debian / patches / use-cython3.patch
71235d0b-adb4-4b86-8514-d1693dc35069/main

Tree @71235d0b-adb4-4b86-8514-d1693dc35069/main (Download .tar.gz)

use-cython3.patch @71235d0b-adb4-4b86-8514-d1693dc35069/mainraw · history · blame

--- a/Makefile
+++ b/Makefile
@@ -25,11 +25,11 @@ docs:
 	make -C docs html SPHINXOPTS=-Aonline=1
 
 release: logbook/_speedups.so
-	python scripts/make-release.py
+	@python scripts/make-release.py
 
 logbook/_speedups.so: logbook/_speedups.pyx
-	cython logbook/_speedups.pyx
-	python setup.py build_ext --inplace
+	cython3 logbook/_speedups.pyx
+	python3 setup.py build_ext --inplace
 
 cybuild: logbook/_speedups.so