Codebase list logbook / bullseye-backports/main debian / patches / use-cython3.patch
bullseye-backports/main

Tree @bullseye-backports/main (Download .tar.gz)

use-cython3.patch @bullseye-backports/mainraw · history · blame

--- a/Makefile
+++ b/Makefile
@@ -25,11 +25,11 @@ docs:
 	make -C docs html SPHINXOPTS=-Aonline=1
 
 release: logbook/_speedups.so
-	python scripts/make-release.py
+	@python scripts/make-release.py
 
 logbook/_speedups.so: logbook/_speedups.pyx
-	cython logbook/_speedups.pyx
-	python setup.py build_ext --inplace
+	cython3 logbook/_speedups.pyx
+	python3 setup.py build_ext --inplace
 
 cybuild: logbook/_speedups.so