Codebase list logbook / e34acae9-f9c1-4d2a-a7b9-91f24ff2b00b/main debian / patches / use-cython3.patch
e34acae9-f9c1-4d2a-a7b9-91f24ff2b00b/main

Tree @e34acae9-f9c1-4d2a-a7b9-91f24ff2b00b/main (Download .tar.gz)

use-cython3.patch @e34acae9-f9c1-4d2a-a7b9-91f24ff2b00b/mainraw · history · blame

--- a/Makefile
+++ b/Makefile
@@ -25,11 +25,11 @@ docs:
 	make -C docs html SPHINXOPTS=-Aonline=1
 
 release: logbook/_speedups.so
-	python scripts/make-release.py
+	@python scripts/make-release.py
 
 logbook/_speedups.so: logbook/_speedups.pyx
-	cython logbook/_speedups.pyx
-	python setup.py build_ext --inplace
+	cython3 logbook/_speedups.pyx
+	python3 setup.py build_ext --inplace
 
 cybuild: logbook/_speedups.so