Codebase list logbook / f0f1fe2 debian / patches / use-cython3.patch
f0f1fe2

Tree @f0f1fe2 (Download .tar.gz)

use-cython3.patch @f0f1fe2raw · history · blame

Description: Use cython3
--- a/Makefile
+++ b/Makefile
@@ -25,11 +25,11 @@ docs:
 	make -C docs html SPHINXOPTS=-Aonline=1
 
 release: logbook/_speedups.so
-	python scripts/make-release.py
+	@python scripts/make-release.py
 
 logbook/_speedups.so: logbook/_speedups.pyx
-	cython logbook/_speedups.pyx
-	python setup.py build_ext --inplace
+	cython3 logbook/_speedups.pyx
+	python3 setup.py build_ext --inplace
 
 cybuild: logbook/_speedups.so