Package list logbook / 09fac50
Update upstream source from tag 'upstream/1.4.3' Update to upstream version '1.4.3' with Debian dir 87437643c3a647ca0de03b0f0288282d4a823889 Downstreamer 2 years ago
4 changed file(s) with 18 addition(s) and 4 deletion(s). Raw diff Collapse all Expand all
2222 script:
2323 - pip install -e .[all]
2424 - if [[ $GEVENT == 'True' ]] ; then pip install gevent; fi
25 - py.test --cov=logbook -r s tests
25 - pytest --cov=logbook -r s tests
2626
2727 matrix:
2828 exclude:
00 Logbook Changelog
11 =================
22
3 Not yet released
3 Version 1.4.3
4 -------------
5
6 Released on January 16th, 2019
7
8 - Fixed Pypi release for 1.4.2
9
10 Version 1.4.2
11 -------------
12
13 Released on December 11th, 2018
414
515 - Use correct record delimiters (null for UNIX, newline for network) in SyslogHandler (thanks Jonathan Kamens)
616 - Try to reconnect to SyslogHandler TCP sockets when they are disconnected (thanks Jonathan Kamens)
919 Here you can see the full list of changes between each Logbook release.
1020
1121 Version 1.4.1
22 -------------
1223
1324 Released on October 14th, 2018
1425
0 __version__ = "1.4.1"
0 __version__ = "1.4.3"
156156 exec(version_file.read()) # pylint: disable=W0122
157157
158158 extras_require = dict()
159 extras_require['test'] = set(['pytest', 'pytest-cov'])
159 if sys.version_info[:2] < (3, 0):
160 extras_require['test'] = set(['pytest', 'pytest-cov<2.6'])
161 else:
162 extras_require['test'] = set(['pytest>4.0', 'pytest-cov>=2.6'])
160163
161164 if sys.version_info[:2] < (3, 3):
162165 extras_require['test'] |= set(['mock'])