Codebase list lwjgl / 28abf7d debian / patches / no-asm-support.patch
28abf7d

Tree @28abf7d (Download .tar.gz)

no-asm-support.patch @28abf7draw · history · blame

Description: No asm support. We don't support the optional asm.jar because LWJGL is not compatible with libasm-java.
Author: Markus Koschany <apo@debian.org>
Forwarded: not-needed
--- a/build.xml
+++ b/build.xml
@@ -476,8 +476,10 @@
             <include name="org/lwjgl/opencl/**"/>
 			<include name="org/lwjgl/util/**"/>
 			<exclude name="org/lwjgl/util/generator/**"/>
+			<exclude name="org/lwjgl/util/mapped/MappedObjectClassLoader.java"/>
+			<exclude name="org/lwjgl/util/mapped/MappedObjectTransformer.java"/>
 		</javac>
-		<javac debug="yes" srcdir="${lwjgl.src}/java/" destdir="${lwjgl.bin}" includes="org/lwjgl/test/**" source="1.5" target="1.5" taskname="test" />
+		<javac debug="yes" srcdir="${lwjgl.src}/java/" destdir="${lwjgl.bin}" includes="org/lwjgl/test/**" source="1.5" target="1.5" taskname="test" excludes="**/TestMappedObject.java,**/SpriteShootoutMapped.java"/>
 		<javac debug="yes" srcdir="${lwjgl.src}/java/" destdir="${lwjgl.bin}" includes="org/lwjgl/examples/**" source="1.5" target="1.5" taskname="examples" />
 	</target>