Codebase list lwjgl / 83cc43d debian / patches / ppc64el.patch
83cc43d

Tree @83cc43d (Download .tar.gz)

ppc64el.patch @83cc43draw · history · blame

Index: lwjgl-2.7.1+dfsg/platform_build/linux_ant/build.xml
===================================================================
--- lwjgl-2.7.1+dfsg.orig/platform_build/linux_ant/build.xml
+++ lwjgl-2.7.1+dfsg/platform_build/linux_ant/build.xml
@@ -23,6 +23,10 @@
 		<exec executable="uname" outputproperty="hwplatform">
 			<arg value="-m"/>
 		</exec>
+		<condition property="cflags_ppc64le" value="-mcpu=powerpc -m64" else="">
+			<os arch="ppc64le"/>
+		</condition>
+		<echo message="value of arch is ${os.arch} the value of hwplatform is ${hwplatform} and cflags32 ${cflags32}" />
 		<condition property="xf86vm_lib" value="-lXxf86vm" else="-Wl,-static,-lXxf86vm,-call_shared">
 			<os name="SunOS" />
 		</condition>
@@ -124,7 +128,7 @@
     <target name="compiledeb">    	
     	<mkdir dir="deb"/>
     	<apply dir="deb" executable="gcc" skipemptyfilesets="true" failonerror="true">
-			<arg line="${cflags32} ${cflags_pthread}"/>
+			<arg line="${cflags32} ${cflags_pthread} ${cflags_ppc64le}"/>
 			<arg value="-I${java.home}/include"/>
 			<arg value="-I${java.home}/include/linux"/>
 			<arg value="-I${java.home}/../include"/>