Codebase list lwjgl / debian/2.9.3+dfsg-3 debian / patches / ppc64el.patch
debian/2.9.3+dfsg-3

Tree @debian/2.9.3+dfsg-3 (Download .tar.gz)

ppc64el.patch @debian/2.9.3+dfsg-3raw · history · blame

From: Markus Koschany <apo@debian.org>
Date: Sat, 9 Apr 2016 19:13:26 +0200
Subject: ppc64el

Support the ppc64el platform. Not absolutely sure if this is still needed
though.

Forwarded: not-needed
---
 platform_build/linux_ant/build.xml | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/platform_build/linux_ant/build.xml b/platform_build/linux_ant/build.xml
index 72eb346..2e9a22e 100644
--- a/platform_build/linux_ant/build.xml
+++ b/platform_build/linux_ant/build.xml
@@ -23,6 +23,10 @@
 		<exec executable="uname" outputproperty="hwplatform">
 			<arg value="-m"/>
 		</exec>
+		<condition property="cflags_ppc64le" value="-mcpu=powerpc -m64" else="">
+			<os arch="ppc64le"/>
+		</condition>
+		<echo message="value of arch is ${os.arch} the value of hwplatform is ${hwplatform} and cflags32 ${cflags32}" />
 		<condition property="cflags_pthread" value="-pthreads" else="-pthread">
 			<os name="SunOS" />
 		</condition>