Codebase list lwjgl / run/3ec689e8-1874-40c2-a9fd-bb2e58406268/main debian / patches / add-missing-symbols-in-native-lib-v2.patch
run/3ec689e8-1874-40c2-a9fd-bb2e58406268/main

Tree @run/3ec689e8-1874-40c2-a9fd-bb2e58406268/main (Download .tar.gz)

add-missing-symbols-in-native-lib-v2.patch @run/3ec689e8-1874-40c2-a9fd-bb2e58406268/mainraw · history · blame

Description: Compile and add to library missing object files
 Some C files present in "src/native/common", and "src/native/linux"
 were not included in the native library build. This patch should include them
 back.
 .
 Also, when building the Debian package, the library "jawt", which is a
 dependency, was missing as well when building the native library.
 .
 This patch should allow building the Debian package with OpenJDK 11.
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=912631#5
Last-Update: 2018-12-31

--- lwjgl-2.9.3+dfsg.orig/platform_build/linux_ant/build.xml
+++ lwjgl-2.9.3+dfsg/platform_build/linux_ant/build.xml
@@ -6,7 +6,7 @@
 	<property name="libname64" value="liblwjgl64.so"/>
 	<property name="libs32" value="-L/usr/X11R6/lib -L/usr/X11/lib -lm -lX11 -lXext -lXcursor -lXrandr -lXxf86vm -lpthread -L${java.home}/lib/i386 -ljawt" />
 	<property name="libs64" value="-L/usr/X11R6/lib64 -L/usr/X11/lib64 -lm -lX11 -lXext -lXcursor -lXrandr -lXxf86vm -lpthread -L${java.home}/lib/amd64 -ljawt" />
-	<property name="libs" value="-L/usr/X11R6/lib -L/usr/X11/lib -lm -lX11 -lXcursor -lXrandr -lXxf86vm -L${java.home}/lib/${os.arch}" />
+	<property name="libs" value="-L/usr/X11R6/lib -L/usr/X11/lib -lm -lX11 -lXcursor -lXrandr -lXxf86vm -L${java.home}/lib -ljawt" />
 	<property name="cflags32" value="-O2 -Wall -c -fPIC -std=c99 -Wunused"/>
 
 	<target name="clean">
@@ -148,8 +148,12 @@
 			<arg value="-I${native}/linux/opengl"/>
 			<mapper type="glob" from="*.c" to="*.o"/>
 			<fileset dir="${native}/linux" includes="*.c"/>
+			<fileset dir="${native}/linux/opengl" includes="*.c"/>
 			<fileset dir="${native}/generated" includes="*.c"/>
-			<fileset dir="${native}/common" includes="*.c"/>
+			<fileset dir="${native}/common" includes="**/*.c" excludes="opengles/**/*"/>
+			<fileset dir="${native}/generated/openal" includes="*.c"/>
+			<fileset dir="${native}/generated/opencl" includes="*.c"/>    		
+			<fileset dir="${native}/generated/opengl" includes="*.c"/>
 		</apply>
 		<apply dir="." parallel="true" executable="gcc" failonerror="true">
 			<srcfile/>
--- lwjgl-2.9.3+dfsg.orig/src/java/org/lwjgl/opengl/Pbuffer.java
+++ lwjgl-2.9.3+dfsg/src/java/org/lwjgl/opengl/Pbuffer.java
@@ -52,6 +52,7 @@ public final class Pbuffer extends Drawa
 	/**
 	 * Indicates that Pbuffers can be created.
 	 */
+	@java.lang.annotation.Native
 	public static final int PBUFFER_SUPPORTED = 1 << 0;
 
 	/**
--- lwjgl-2.9.3+dfsg.orig/src/native/linux/opengl/org_lwjgl_opengl_Pbuffer.c
+++ lwjgl-2.9.3+dfsg/src/native/linux/opengl/org_lwjgl_opengl_Pbuffer.c
@@ -42,6 +42,7 @@
 #include <stdlib.h>
 #include "org_lwjgl_opengl_LinuxPbufferPeerInfo.h"
 #include "org_lwjgl_opengl_Pbuffer.h"
+#include "org_lwjgl_opengl_LinuxDisplay.h"
 #include "extgl.h"
 #include "context.h"
 #include "common_tools.h"