Codebase list lwjgl / scrub-obsolete/main debian / patches / ppc64el.patch
scrub-obsolete/main

Tree @scrub-obsolete/main (Download .tar.gz)

ppc64el.patch @scrub-obsolete/mainraw · history · blame

Description: Support the ppc64el platform. Not absolutely sure if this is still needed though.
Author: Markus Koschany <apo@debian.org>
Forwarded: not-needed
--- a/platform_build/linux_ant/build.xml
+++ b/platform_build/linux_ant/build.xml
@@ -23,6 +23,10 @@
 		<exec executable="uname" outputproperty="hwplatform">
 			<arg value="-m"/>
 		</exec>
+		<condition property="cflags_ppc64le" value="-mcpu=powerpc -m64" else="">
+			<os arch="ppc64le"/>
+		</condition>
+		<echo message="value of arch is ${os.arch} the value of hwplatform is ${hwplatform} and cflags32 ${cflags32}" />
 		<condition property="cflags_pthread" value="-pthreads" else="-pthread">
 			<os name="SunOS" />
 		</condition>