Codebase list mozc / 1e0601e debian / patches / bug107_request_surrounding_text.patch
1e0601e

Tree @1e0601e (Download .tar.gz)

bug107_request_surrounding_text.patch @1e0601eraw · history · blame

Description: Initial reconversion after turning IBus on doesn't start
Forwarded: not-needed
Origin: vendor, http://code.google.com/p/mozc/issues/detail?id=107
Bug-Debian: none
Author: Irie 

Index: src/unix/ibus/mozc_engine.cc
===================================================================
--- src/unix/ibus/mozc_engine.cc	(revision 81)
+++ src/unix/ibus/mozc_engine.cc	(working copy)
@@ -473,6 +473,13 @@
   // Stop ignoring "reset" signal.  See ProcessKeyevent().
   ignore_reset_for_deletion_range_workaround_ = false;
 
+#if IBUS_CHECK_VERSION(1, 4, 0)
+  // Call ibus_engine_get_surrounding_text() to emit "RequireSurroundingText"
+  // signal. In the following line, the second argument NULL means "only send
+  // the signal".
+  ibus_engine_get_surrounding_text(engine, NULL, NULL, NULL);
+#endif  // IBUS_CHECK_VERSION(1, 4, 0)
+
   // Launch mozc_server
   client_->EnsureConnection();
   UpdatePreeditMethod();