Codebase list node-d3-shape / debian/1.2.0-1 debian / rules
debian/1.2.0-1

Tree @debian/1.2.0-1 (Download .tar.gz)

rules @debian/1.2.0-1raw · history · blame

#!/usr/bin/make -f
# -*- makefile -*-

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

%:
	dh $@

override_dh_auto_build:
	babeljs src -d lib
	babeljs index.js -d lib
	sed -i 's/.\/src/./' lib/index.js
# TODO: investigate segfault
#	webpack --config debian/webpack.config.js index.js build/d3-shape.js --target=web --output-library=d3-shape --output-library-target=umd --module-bind 'js=babel-loader'

override_dh_auto_test:
	tape 'test/**/*.js'

override_dh_auto_clean:
	rm -rf lib build
	dh_auto_clean