Codebase list orafce / 569e95d debian / tests / installcheck
569e95d

Tree @569e95d (Download .tar.gz)

installcheck @569e95draw · history · blame

#!/bin/sh

set -e

case $(lsb_release -is) in
Debian)
	if ! grep -Fwq "en_US.UTF-8 UTF-8" /etc/locale.gen; then
		echo "en_US.UTF-8 UTF-8" >> /etc/locale.gen
		locale-gen
	fi
	;;
Ubuntu)
	locale-gen en_US.UTF-8
	;;
esac

# to_multi_byte needs English, and UTF-8
export LC_ALL=en_US.utf8

for v in $(pg_buildext supported-versions); do
	rm -f orafunc.sql.in orafunc.sql
	make orafunc.sql PG_CONFIG=/usr/lib/postgresql/$v/bin/pg_config
	# ignore problems with createexplicitpipe and to_char on lucid
	# ($distribution is set in the apt.postgresql.org build environment)
	pg_buildext installcheck-$v || [ "$distribution" = "lucid" ]
done