Codebase list orafce / 79f2ea8 debian / tests / installcheck
79f2ea8

Tree @79f2ea8 (Download .tar.gz)

installcheck @79f2ea8raw · history · blame

#!/bin/sh

# to_multi_byte needs English, and UTF-8
export LC_ALL=en_US.utf8

set -e
for v in $(pg_buildext supported-versions); do
	case $v in
		# older versions fail on concat, ignore that
		# ERROR:  function concat(unknown, unknown) does not exist
		8*|9.0) FAIL="exit 0" ;;
		*) FAIL="exit 1" ;;
	esac
	pg_buildext installcheck-$v || $FAIL
done