Codebase list orafce / a98de0b debian / tests / installcheck
a98de0b

Tree @a98de0b (Download .tar.gz)

installcheck @a98de0braw · history · blame

#!/bin/sh

if [ -f /etc/locale.gen ]; then
	# Debian
	grep -Fq "en_US.UTF-8 UTF-8" || echo "en_US.UTF-8 UTF-8" >> /etc/locale.gen
	locale-gen
else
	# Ubuntu
	locale-gen en_US.UTF-8
fi

# to_multi_byte needs English, and UTF-8
export LC_ALL=en_US.utf8

set -e
for v in $(pg_buildext supported-versions); do
	rm -f orafunc.sql.in orafunc.sql
	make orafunc.sql PG_CONFIG=/usr/lib/postgresql/$v/bin/pg_config
	pg_buildext installcheck-$v
done