Codebase list pangzero / debian/1.4.1+git20121103-4 debian / patches / fix-pause-crash.patch
debian/1.4.1+git20121103-4

Tree @debian/1.4.1+git20121103-4 (Download .tar.gz)

fix-pause-crash.patch @debian/1.4.1+git20121103-4raw · history · blame

From: Markus Koschany <apo@debian.org>
Date: Mon, 13 Mar 2017 08:55:15 +0100
Subject: fix pause crash

Forwarded: https://github.com/kthakore/pangzero/issues/5
Bug-Debian: https://bugs.debian.org/857474
---
 lib/Games/PangZero.pm | 1 -
 1 file changed, 1 deletion(-)

diff --git a/lib/Games/PangZero.pm b/lib/Games/PangZero.pm
index e9e4dd6..7015fec 100644
--- a/lib/Games/PangZero.pm
+++ b/lib/Games/PangZero.pm
@@ -165,7 +165,6 @@ sub Pause {
 
   SDL::Video::blit_surface($pausedSurface, SDL::Rect->new(0, 0, $pausedSurface->w, $pausedSurface->h),
                            $App, SDL::Rect->new(($PhysicalScreenWidth - $pausedSurface->w) / 2, $PhysicalScreenHeight / 2 - 100, 0, 0));
-  $App->sync();
   $Keys   = ();
   $Events = ();
   while (1) { # Paused, wait for keypress