Codebase list pnm2ppa / debian/1.13-1 debian / rules
debian/1.13-1

Tree @debian/1.13-1 (Download .tar.gz)

rules @debian/1.13-1raw · history · blame

#!/usr/bin/make -f
#export DH_VERBOSE=1

CFLAGS=-DLANG_EN -O2 -Wall

%:
	dh $@ --parallel --builddirectory=build/

override_dh_auto_install:
	dh_auto_install --builddirectory=build/
	# Move the configuration file from /etc to /usr/share
	mv debian/pnm2ppa/etc/pnm2ppa.conf debian/pnm2ppa/usr/share/pnm2ppa/

override_dh_install:
	dh_install
	# Make sure update-magicfilters is executable
	chmod +x debian/pnm2ppa/usr/share/pnm2ppa/update-magicfilter

override_dh_installdocs: 
	dh_installdocs
	# Remove useless or redundant files
	cd debian/pnm2ppa/usr/share/doc/pnm2ppa/;\
		rm en/CREDITS;\
		rm en/INSTALL.BEOS;\
		rm en/INSTALL.CALDERA;\
		rm en/INSTALL.MANDRAKE*;\
		rm en/INSTALL.REDHAT*;\
		rm en/INSTALL.SOLARIS;\
		rm en/INSTALL.SUSE;\
		rm en/INSTALL;\
		rm en/LICENSE;\
		rm en/README;\
		rm en/RELEASE-NOTES;\
		rm en/TODO;\
		rm en/pnm2ppa.1;\
		rm pl/INSTALACJA;\
		rm pl/INSTALACJA.SUSE