Add patch to build the make_hash_ink buildtool natively, with the correct buildflags; use dh-autoreconf to cope with the change
Didier Raboud
9 years ago
2 | 2 |
Priority: optional
|
3 | 3 |
Maintainer: Debian Printing Team <debian-printing@lists.debian.org>
|
4 | 4 |
Uploaders: Didier Raboud <odyx@debian.org>
|
5 | |
Build-Depends: debhelper (>= 8.9.0~), autotools-dev
|
|
5 |
Build-Depends: debhelper (>= 8.9.0~), autotools-dev, dh-autoreconf
|
6 | 6 |
Homepage: http://pnm2ppa.sf.net/
|
7 | 7 |
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=printing/pnm2ppa.git
|
8 | 8 |
Vcs-Git: https://alioth.debian.org/anonscm/git/printing/pnm2ppa.git
|
|
0 |
Description: Build make_hash_ink natively, hence use the buildflags
|
|
1 |
Author: Didier Raboud <odyx@debian.org>
|
|
2 |
Last-Update: 2014-03-06
|
|
3 |
--- a/Makefile.am
|
|
4 |
+++ b/Makefile.am
|
|
5 |
@@ -128,5 +128,5 @@
|
|
6 |
LDFLAGS_FOR_BUILD =
|
|
7 |
LDLIBS_FOR_BUILD =
|
|
8 |
|
|
9 |
-make_hash_ink: make_hash_ink.c
|
|
10 |
- $(CC_FOR_BUILD) $(CPPFLAGS_FOR_BUILD) $(CFLAGS_FOR_BUILD) $(LDFLAGS_FOR_BUILD) -o $@ $< $(LDLIBS_FOR_BUILD)
|
|
11 |
+noinst_PROGRAMS = make_hash_ink
|
|
12 |
+make_hash_ink_SOURCES = make_hash_ink.c
|
|
0 |
00_use_env_buildflags.patch
|
0 | 1 |
10_177295-fix_signedness.patch
|
1 | 2 |
99-examples_shbangs.patch
|
2 | 3 |
99-pnm2ppa_manpage.patch
|
5 | 5 |
CFLAGS += -DLANG_ENG -Wall
|
6 | 6 |
|
7 | 7 |
%:
|
8 | |
dh $@ --parallel --builddirectory=build/ --with autotools_dev
|
|
8 |
dh $@ --parallel --builddirectory=build/ --with autotools_dev,autoreconf
|
9 | 9 |
|
10 | 10 |
override_dh_auto_install:
|
11 | 11 |
dh_auto_install --builddirectory=build/ --destdir=debian/printer-driver-pnm2ppa/
|