Codebase list python-certbot-dns-rfc2136 / 00b9f1f5-e8a9-4947-9d58-4a6eb80691fc/main debian / rules
00b9f1f5-e8a9-4947-9d58-4a6eb80691fc/main

Tree @00b9f1f5-e8a9-4947-9d58-4a6eb80691fc/main (Download .tar.gz)

rules @00b9f1f5-e8a9-4947-9d58-4a6eb80691fc/mainraw · history · blame

#!/usr/bin/make -f

export PYBUILD_NAME = certbot-dns-rfc2136

%:
	dh $@ --with python3,sphinxdoc --buildsystem=pybuild

override_dh_auto_build:
	dh_auto_build
	PYTHONPATH=. \
		http_proxy='127.0.0.1:9' \
		https_proxy='127.0.0.1:9' \
		sphinx-build -N -bhtml docs/ build/html

override_dh_installdocs:
	dh_installdocs --doc-main-package=python3-certbot-dns-rfc2136 \
		-p python-certbot-dns-rfc2136-doc
	dh_installdocs -p python3-certbot-dns-rfc2136