Codebase list python-certbot-dns-rfc2136 / 0dc385e4-220e-4f04-aaf1-95a685cb2832/main debian / rules
0dc385e4-220e-4f04-aaf1-95a685cb2832/main

Tree @0dc385e4-220e-4f04-aaf1-95a685cb2832/main (Download .tar.gz)

rules @0dc385e4-220e-4f04-aaf1-95a685cb2832/mainraw · history · blame

#!/usr/bin/make -f

export PYBUILD_NAME = certbot-dns-rfc2136

%:
	dh $@ --with python3,sphinxdoc --buildsystem=pybuild

override_dh_auto_build:
	dh_auto_build
	PYTHONPATH=. \
		http_proxy='127.0.0.1:9' \
		https_proxy='127.0.0.1:9' \
		sphinx-build -N -bhtml docs/ build/html

override_dh_installdocs:
	dh_installdocs --doc-main-package=python3-certbot-dns-rfc2136 \
		-p python-certbot-dns-rfc2136-doc
	dh_installdocs -p python3-certbot-dns-rfc2136