Codebase list python-certbot-dns-rfc2136 / debian/0.35.1-1 debian / rules
debian/0.35.1-1

Tree @debian/0.35.1-1 (Download .tar.gz)

rules @debian/0.35.1-1raw · history · blame

#!/usr/bin/make -f

export PYBUILD_NAME = certbot-dns-rfc2136

%:
	dh $@ --with python3,sphinxdoc --buildsystem=pybuild

override_dh_auto_build:
	dh_auto_build
	PYTHONPATH=. \
		http_proxy='127.0.0.1:9' \
		https_proxy='127.0.0.1:9' \
		sphinx-build -N -bhtml docs/ build/html

override_dh_installdocs:
	dh_installdocs --doc-main-package=python3-certbot-dns-rfc2136 \
		-p python-certbot-dns-rfc2136-doc
	dh_installdocs -p python3-certbot-dns-rfc2136