Codebase list python-pauvre / 066a8b2 debian / patches / fix-scikit-learn-resource-load.patch
066a8b2

Tree @066a8b2 (Download .tar.gz)

fix-scikit-learn-resource-load.patch @066a8b2raw · history · blame

Description: require scikit-learn instead of sklearn
 This fixes a problem in pkg_resource loading when trying to start pauvre with
 the provided command line interface.  See the following for more details:
     https://lists.debian.org/debian-python/2020/04/msg00146.html
 Not sure yet if this is Debian specific.  If not it might be worth contacting
 upstream.
Author: Etienne Mollier <etienne.mollier@mailoo.org>
Forwarded: no
Last-Update: 2020-04-27
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- python-pauvre.orig/setup.py
+++ python-pauvre/setup.py
@@ -65,7 +65,7 @@
           "pandas >= 0.20.1",
           "numpy >= 1.12.1",
           "scipy",
-          "sklearn"
+          "scikit-learn"
       ],
       entry_points={
           'console_scripts': ['pauvre=pauvre.pauvre_main:main'],