Codebase list python-pauvre / 487352f debian / rules
487352f

Tree @487352f (Download .tar.gz)

rules @487352fraw · history · blame

#!/usr/bin/make -f

# DH_VERBOSE := 1
export LC_ALL=C.UTF-8

include /usr/share/dpkg/default.mk
# this provides:
# DEB_SOURCE: the source package name
# DEB_VERSION: the full version of the package (epoch + upstream vers. + revision)
# DEB_VERSION_EPOCH_UPSTREAM: the package's version without the Debian revision
# DEB_VERSION_UPSTREAM_REVISION: the package's version without the Debian epoch
# DEB_VERSION_UPSTREAM: the package's upstream version
# DEB_DISTRIBUTION: the distribution(s) listed in the current entry of debian/changelog
# SOURCE_DATE_EPOCH: the source release date as seconds since the epoch, as
#                    specified by <https://reproducible-builds.org/specs/source-date-epoch/>

# for hardening you might like to uncomment this:
# export DEB_BUILD_MAINT_OPTIONS=hardening=+all

%:
	dh $@ --with python3 --buildsystem=pybuild

override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
	PYBUILDDIR="$$(echo "$(CURDIR)"/.pybuild/cpython3_3.*/build)" \
	&& mkdir -p "$${PYBUILDDIR}/pauvre/tests/testdata/alignments" \
		"$${PYBUILDDIR}/pauvre/tests/testresults" \
	&& cp -r "$(CURDIR)/debian/tests/gff_files" \
		"$${PYBUILDDIR}/pauvre/tests/testdata" \
	&& BUILDDIR="$${PYBUILDDIR}" PATH="$(CURDIR)/debian/bin:$$PATH" \
		dh_auto_test
endif