Codebase list python-pauvre / ed9e8e8 debian / patches / lsi-test-args.patch
ed9e8e8

Tree @ed9e8e8 (Download .tar.gz)

lsi-test-args.patch @ed9e8e8raw · history · blame

Description: inject arguments in test script
 The script expects a few arguments which are not passed by the testing
 infrastructure.  This breaks the test.  The integer value in sys.argv[1] is
 picked at random, but could be subject to discussion.
Author: Étienne Mollier <etienne.mollier@mailoo.org>
Forwarded: not-needed
Last-Update: 2020-04-26
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
Index: python-pauvre/pauvre/lsi/test.py
===================================================================
--- python-pauvre.orig/pauvre/lsi/test.py
+++ python-pauvre/pauvre/lsi/test.py
@@ -10,6 +10,9 @@ from .helper import *
 
 ev = 0.00000001
 
+sys.argv[1] = '10'
+sys.argv[2] = None
+
 def scale(i):
 	return float(i)