Package list python-procrunner / 4d1dfb47-bcaf-4acf-a813-b0e8120fdfb5/main
Reading package lists... 0%Reading package lists... 0%Reading package lists... 0%Reading package lists... 99%Reading package lists... 99%Reading package lists... Done Building dependency tree... 0%Building dependency tree... 0%Building dependency tree... 50%Building dependency tree... 50%Building dependency tree... 85%Building dependency tree... Done Reading state information... 0% Reading state information... 0%Reading state information... Done Connecting to api.ftp-master.debian.org to check 6 package versions. Please wait... Got info from api.ftp-master.debian.org for 6 packages. Changes applied to dpkg configuration: - control source Standards-Version: '4.5.0' -> '4.6.0' # applied fix for :Current standards version is '4.6.0'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version '4.5.0' to '4.6.0'. - compat deleted value: '12' - control source Build-Depends:0: 'debhelper (>= 12)' -> 'debhelper-compat (= 12)' # applied fix for :Cleared deprecated compat value; changed debhelper dependency to debhelper dependency - copyright License: rename key from 'BSD-3' to 'BSD-3-clause' - copyright Files:"*" License short_name: 'BSD-3' -> 'BSD-3-clause' # applied fix for :Please use BSD-x-clause name, like BSD-3-clause - copyright Files:"debian/*" License short_name: 'BSD-3' -> 'BSD-3-clause' # applied fix for :Please use BSD-x-clause name, like BSD-3-clause Debian Janitor 2 months ago
4 changed file(s) with 46 addition(s) and 12 deletion(s). Raw diff Collapse all Expand all
0 python-procrunner (1.1.0-2) UNRELEASED; urgency=medium
1
2 * Reading package lists... 0%Reading package lists... 0%Reading package
3 lists... 0%Reading package lists... 99%Reading package lists... 99%Reading
4 package lists... Done Building dependency tree... 0%Building dependency
5 tree... 0%Building dependency tree... 50%Building dependency tree...
6 50%Building dependency tree... 85%Building dependency tree... Done Reading
7 state information... 0% Reading state information... 0%Reading state
8 information... Done Connecting to api.ftp-master.debian.org to check 6
9 package versions. Please wait... Got info from api.ftp-master.debian.org for
10 6 packages. Changes applied to dpkg configuration: - control source
11 Standards-Version: '4.5.0' -> '4.6.0' # applied fix for :Current standards
12 version is '4.6.0'. Please read
13 https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the
14 changes that may be needed on your package to upgrade it from standard
15 version '4.5.0' to '4.6.0'. - compat deleted value: '12' - control source
16 Build-Depends:0: 'debhelper (>= 12)' -> 'debhelper-compat (= 12)' # applied
17 fix for :Cleared deprecated compat value; changed debhelper dependency to
18 debhelper dependency - copyright License: rename key from 'BSD-3' to
19 'BSD-3-clause' - copyright Files:"*" License short_name: 'BSD-3' ->
20 'BSD-3-clause' # applied fix for :Please use BSD-x-clause name, like
21 BSD-3-clause - copyright Files:"debian/*" License short_name: 'BSD-3' ->
22 'BSD-3-clause' # applied fix for :Please use BSD-x-clause name, like
23 BSD-3-clause
24
25 -- Debian Janitor <janitor@jelmer.uk> Fri, 17 Sep 2021 06:20:13 -0000
26
027 python-procrunner (1.1.0-1) unstable; urgency=medium
128
229 * First release (Closes: #962456)
+0
-1
debian/compat less more
0 12
00 Source: python-procrunner
1 Maintainer: Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
2 Uploaders: Sebastien Delafond <seb@debian.org>
13 Section: python
24 Priority: optional
3 Maintainer: Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
4 Uploaders: Sebastien Delafond <seb@debian.org>
5 Build-Depends: debhelper (>= 12), dh-python, python3-setuptools, python3-all, python3-pytest-runner, python3-pytest, python3-mock
6 Standards-Version: 4.5.0
7 Homepage: https://github.com/DiamondLightSource/python-procrunner
5 Build-Depends: debhelper-compat (= 12),
6 dh-python,
7 python3-setuptools,
8 python3-all,
9 python3-pytest-runner,
10 python3-pytest,
11 python3-mock
12 Standards-Version: 4.6.0
813 Vcs-Browser: https://salsa.debian.org/science-team/python-procrunner
914 Vcs-Git: https://salsa.debian.org/science-team/python-procrunner.git
15 Homepage: https://github.com/DiamondLightSource/python-procrunner
1016
1117 Package: python3-procrunner
1218 Architecture: all
13 Depends: ${misc:Depends}, ${shlibs:Depends}, ${python3:Depends}
19 Depends: ${misc:Depends},
20 ${shlibs:Depends},
21 ${python3:Depends}
1422 Description: Versatile utility function to run external processes from Python
1523 Versatile utility function to run external processes from Python, with many
1624 features:
33
44 Files: *
55 Copyright: Markus Gerstel; 2018 Diamond Light Source.
6 License: BSD-3
6 License: BSD-3-clause
77
88 Files: debian/*
99 Copyright: 2020 Sebastien Delafond <seb@debian.org>
10 License: BSD-3
10 License: BSD-3-clause
1111
12 License: BSD-3
12 License: BSD-3-clause
1313 Copyright (c) The Regents of the University of California.
1414 All rights reserved.
15 .
15 .
1616 Redistribution and use in source and binary forms, with or without
1717 modification, are permitted provided that the following conditions
1818 are met:
2424 3. Neither the name of the University nor the names of its contributors
2525 may be used to endorse or promote products derived from this software
2626 without specific prior written permission.
27 .
27 .
2828 THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
2929 ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
3030 IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE