Package list python-procrunner / 5258eb5
Bump version: 0.9.0 → 0.9.1 Markus Gerstel 2 years ago
4 changed file(s) with 12 addition(s) and 4 deletion(s). Raw diff Collapse all Expand all
00 =======
11 History
22 =======
3
4 0.9.1 (2019-02-22)
5 ------------------
6
7 * Have deprecation warnings point to correct code locations
38
49 0.9.0 (2018-12-07)
510 ------------------
5252
5353 __author__ = """Markus Gerstel"""
5454 __email__ = "scientificsoftware@diamond.ac.uk"
55 __version__ = "0.9.0"
55 __version__ = "0.9.1"
5656
5757 logger = logging.getLogger("procrunner")
5858 logger.addHandler(logging.NullHandler())
515515 def run_process_dummy(command, **kwargs):
516516 """A stand-in function that returns a valid result dictionary indicating a
517517 successful execution. The external process is not run."""
518 warnings.warn("procrunner.run_process_dummy() is deprecated", DeprecationWarning)
518 warnings.warn(
519 "procrunner.run_process_dummy() is deprecated", DeprecationWarning, stacklevel=2
520 )
519521
520522 time_start = time.strftime("%Y-%m-%d %H:%M:%S GMT", time.gmtime())
521523 logger.info("run_process is disabled. Requested command: %s", command)
542544 warnings.warn(
543545 "procrunner.run_process() is deprecated and has been renamed to run()",
544546 DeprecationWarning,
547 stacklevel=2,
545548 )
546549 return run(*args, **kwargs)
00 [bumpversion]
1 current_version = 0.9.0
1 current_version = 0.9.1
22 commit = True
33 tag = True
44
5555 test_suite="tests",
5656 tests_require=test_requirements,
5757 url="https://github.com/DiamondLightSource/python-procrunner",
58 version="0.9.0",
58 version="0.9.1",
5959 zip_safe=False,
6060 )