Package list python-procrunner / fbc1a2f
Scheduled monthly dependency update for July (#26) * Update tox from 3.12.1 to 3.13.1 * Stick with pytest<5 for as long as we have to support Python 2.7 * use requirements file for appveyor builds pyup.io bot authored 2 years ago Markus Gerstel committed 2 years ago
2 changed file(s) with 3 addition(s) and 2 deletion(s). Raw diff Collapse all Expand all
2626 install:
2727 # Upgrade to the latest pip.
2828 - '%PYTHON%\\python.exe -m pip install -U pip setuptools wheel'
29 - '%PYTHON%\\python.exe -m pip install -r requirements_dev.txt'
2930 # Install win32api dependency. Must use the --only-binary switch explicitly
3031 # on AppVeyor
3132 - "%PYTHON%\\python.exe -m pip install --only-binary pywin32 pywin32"
22 flake8==3.7.7
33 mock==3.0.5
44 pip==19.1.1
5 pytest==4.5.0
5 pytest==4.5.0 # pyup: <5.0 # for Python 2.7 support
66 pytest-runner==5.1
77 six==1.12.0
88 Sphinx==1.8.5 # pyup: <2.0 # for Python 2.7 and 3.4 support
9 tox==3.12.1
9 tox==3.13.1
1010 twine==1.13.0
1111 watchdog==0.9.0
1212 wheel==0.33.4