Codebase list readosm / ca408691-41f7-4111-aac2-ff225d237c53/main debian / rules
ca408691-41f7-4111-aac2-ff225d237c53/main

Tree @ca408691-41f7-4111-aac2-ff225d237c53/main (Download .tar.gz)

rules @ca408691-41f7-4111-aac2-ff225d237c53/mainraw · history · blame

#!/usr/bin/make -f
# -*- makefile -*-

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

# Enable hardening build flags
export DEB_BUILD_MAINT_OPTIONS=hardening=+all

include /usr/share/dpkg/pkg-info.mk

UPSTREAM_VERSION=$(shell echo $(DEB_VERSION_UPSTREAM) | sed -e 's/\+.*//')

%:
	dh $@

override_dh_clean:
	dh_clean
	rm -rf html/ latex/

override_dh_auto_build:
	dh_auto_build
	doxygen

override_dh_install:
	# Remove useless autogenreated doxygen files
	rm -f html/*.md5

	# Remove .la files
	find debian/tmp/usr/lib/ -type f -name "*.la" -delete

	dh_install

override_dh_makeshlibs:
	dh_makeshlibs -- -v$(UPSTREAM_VERSION)

override_dh_strip:
	dh_strip --dbgsym-migration='libreadosm1-dbg (<< 1.1.0+dfsg-2~)'