Codebase list readosm / debian/1.1.0+dfsg-2 debian / rules
debian/1.1.0+dfsg-2

Tree @debian/1.1.0+dfsg-2 (Download .tar.gz)

rules @debian/1.1.0+dfsg-2raw · history · blame

#!/usr/bin/make -f
# -*- makefile -*-

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

# Enable hardening build flags
export DEB_BUILD_MAINT_OPTIONS=hardening=+all

include /usr/share/dpkg/pkg-info.mk

UPSTREAM_VERSION=$(shell echo $(DEB_VERSION_UPSTREAM) | sed -e 's/\+.*//')

%:
	dh $@ --with autoreconf --parallel

override_dh_clean:
	dh_clean
	rm -rf html/ latex/

override_dh_auto_build:
	dh_auto_build
	doxygen

override_dh_install:
	# Remove useless autogenreated doxygen files
	rm -f html/*.md5

	# Remove .la files
	find debian/tmp/usr/lib/ -type f -name "*.la" -delete

	dh_install --list-missing

override_dh_makeshlibs:
	dh_makeshlibs -- -v$(UPSTREAM_VERSION)

override_dh_strip:
	dh_strip --dbgsym-migration='libreadosm1-dbg (<< 1.1.0+dfsg-2~)'