Package list ruby-fog-vmfusion / fresh-snapshots/upstream
Import upstream version 0.1.0+git20170904.1.88fe1b4 Debian Janitor 25 days ago
5 changed file(s) with 17 addition(s) and 195 deletion(s). Raw diff Collapse all Expand all
0 .rubocop.yml
0 2.1.4
0 2.4.1
0 language: ruby
1
2 sudo: false
3 dist: trusty
4
5 script: bundle exec rake test
6
7 rvm:
8 - 2.1
9 - 2.2
10 - 2.3
11 - 2.4
12 - jruby-head
013 matrix:
114 include:
2 - rvm: 1.8.7
3 gemfile: gemfiles/Gemfile.1.9.2-
4 - rvm: 1.9.2
5 gemfile: gemfiles/Gemfile.1.9.2-
6 - rvm: 1.9.3
7 gemfile: gemfiles/Gemfile.1.9.3+
8 - rvm: 2.0.0
9 gemfile: gemfiles/Gemfile.1.9.3+
10 - rvm: 2.1.4
11 gemfile: gemfiles/Gemfile.1.9.3+
15 - rvm: 2.4
1216 env: COVERAGE=true
13 - rvm: ree
14 gemfile: gemfiles/Gemfile.1.9.2-
15 - rvm: jruby
16 gemfile: gemfiles/Gemfile.1.9.3+
0 module Vmfusion # deviates from other bin stuff to accomodate gem
0 module Vmfusion # deviates from other bin stuff to accommodate gem
11 class << self
22 def class_for(key)
33 case key
+0
-179
metadata.yml less more
0 --- !ruby/object:Gem::Specification
1 name: fog-vmfusion
2 version: !ruby/object:Gem::Version
3 version: 0.1.0
4 platform: ruby
5 authors:
6 - Paulo Henrique Lopes Ribeiro
7 autorequire:
8 bindir: bin
9 cert_chain: []
10 date: 2015-04-04 00:00:00.000000000 Z
11 dependencies:
12 - !ruby/object:Gem::Dependency
13 name: fog-core
14 requirement: !ruby/object:Gem::Requirement
15 requirements:
16 - - ">="
17 - !ruby/object:Gem::Version
18 version: '0'
19 type: :runtime
20 prerelease: false
21 version_requirements: !ruby/object:Gem::Requirement
22 requirements:
23 - - ">="
24 - !ruby/object:Gem::Version
25 version: '0'
26 - !ruby/object:Gem::Dependency
27 name: fission
28 requirement: !ruby/object:Gem::Requirement
29 requirements:
30 - - ">="
31 - !ruby/object:Gem::Version
32 version: '0'
33 type: :runtime
34 prerelease: false
35 version_requirements: !ruby/object:Gem::Requirement
36 requirements:
37 - - ">="
38 - !ruby/object:Gem::Version
39 version: '0'
40 - !ruby/object:Gem::Dependency
41 name: rake
42 requirement: !ruby/object:Gem::Requirement
43 requirements:
44 - - ">="
45 - !ruby/object:Gem::Version
46 version: '0'
47 type: :development
48 prerelease: false
49 version_requirements: !ruby/object:Gem::Requirement
50 requirements:
51 - - ">="
52 - !ruby/object:Gem::Version
53 version: '0'
54 - !ruby/object:Gem::Dependency
55 name: minitest
56 requirement: !ruby/object:Gem::Requirement
57 requirements:
58 - - ">="
59 - !ruby/object:Gem::Version
60 version: '0'
61 type: :development
62 prerelease: false
63 version_requirements: !ruby/object:Gem::Requirement
64 requirements:
65 - - ">="
66 - !ruby/object:Gem::Version
67 version: '0'
68 - !ruby/object:Gem::Dependency
69 name: turn
70 requirement: !ruby/object:Gem::Requirement
71 requirements:
72 - - ">="
73 - !ruby/object:Gem::Version
74 version: '0'
75 type: :development
76 prerelease: false
77 version_requirements: !ruby/object:Gem::Requirement
78 requirements:
79 - - ">="
80 - !ruby/object:Gem::Version
81 version: '0'
82 - !ruby/object:Gem::Dependency
83 name: pry
84 requirement: !ruby/object:Gem::Requirement
85 requirements:
86 - - ">="
87 - !ruby/object:Gem::Version
88 version: '0'
89 type: :development
90 prerelease: false
91 version_requirements: !ruby/object:Gem::Requirement
92 requirements:
93 - - ">="
94 - !ruby/object:Gem::Version
95 version: '0'
96 - !ruby/object:Gem::Dependency
97 name: coveralls
98 requirement: !ruby/object:Gem::Requirement
99 requirements:
100 - - ">="
101 - !ruby/object:Gem::Version
102 version: '0'
103 type: :development
104 prerelease: false
105 version_requirements: !ruby/object:Gem::Requirement
106 requirements:
107 - - ">="
108 - !ruby/object:Gem::Version
109 version: '0'
110 - !ruby/object:Gem::Dependency
111 name: rubocop
112 requirement: !ruby/object:Gem::Requirement
113 requirements:
114 - - ">="
115 - !ruby/object:Gem::Version
116 version: '0'
117 type: :development
118 prerelease: false
119 version_requirements: !ruby/object:Gem::Requirement
120 requirements:
121 - - ">="
122 - !ruby/object:Gem::Version
123 version: '0'
124 description: |-
125 This library can be used as a module for `fog` or as standalone provider
126 to use the VMWARE FUSION in applications.
127 email: plribeiro3000@gmail.com
128 executables: []
129 extensions: []
130 extra_rdoc_files: []
131 files:
132 - ".gitignore"
133 - ".rubocop.yml"
134 - ".ruby-gemset"
135 - ".ruby-version"
136 - ".travis.yml"
137 - CONTRIBUTING.md
138 - CONTRIBUTORS.md
139 - Gemfile
140 - LICENSE.md
141 - README.md
142 - Rakefile
143 - fog-vmfusion.gemspec
144 - gemfiles/Gemfile.1.9.2-
145 - gemfiles/Gemfile.1.9.3+
146 - lib/fog/bin/vmfusion.rb
147 - lib/fog/compute/vmfusion.rb
148 - lib/fog/compute/vmfusion/server.rb
149 - lib/fog/compute/vmfusion/servers.rb
150 - lib/fog/vmfusion.rb
151 - lib/fog/vmfusion/version.rb
152 - spec/minitest_helper.rb
153 homepage: ''
154 licenses:
155 - MIT
156 metadata: {}
157 post_install_message:
158 rdoc_options: []
159 require_paths:
160 - lib
161 required_ruby_version: !ruby/object:Gem::Requirement
162 requirements:
163 - - ">="
164 - !ruby/object:Gem::Version
165 version: '0'
166 required_rubygems_version: !ruby/object:Gem::Requirement
167 requirements:
168 - - ">="
169 - !ruby/object:Gem::Version
170 version: '0'
171 requirements: []
172 rubyforge_project:
173 rubygems_version: 2.4.2
174 signing_key:
175 specification_version: 4
176 summary: Module for the 'fog' gem to support VMWARE FUSION.
177 test_files:
178 - spec/minitest_helper.rb