Codebase list ruby-gitlab / 42b2e2a debian / patches / drop-git-ls-files.patch
42b2e2a

Tree @42b2e2a (Download .tar.gz)

drop-git-ls-files.patch @42b2e2araw · history · blame

Description: Drop git ls-files in .gemspec
 Replace the git ls-files with Dir.glob as build is not in git directory
Author: Sophie Brun <sophie@freexian.com>
Last-Update: 2018-08-20
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/gitlab.gemspec
+++ b/gitlab.gemspec
@@ -11,7 +11,7 @@
   gem.summary       = 'A Ruby wrapper and CLI for the GitLab API'
   gem.homepage      = 'https://github.com/narkoz/gitlab'
 
-  gem.files         = `git ls-files`.split($/).
+  gem.files         = Dir.glob('**/*').
                       reject { |f| f[/^spec/] } -
                       %w[Dockerfile docker-compose.yml docker.env .travis.yml .rubocop.yml .dockerignore]
   gem.bindir        = 'exe'